Friday, April 15, 2011

Ubuntu 10.04 on dell inspiron 8100

Now installing ubuntu 10.04 after 9 became unusable.

1. Once again had to use floppy to then boot to usb.
2. Tried installing with 10.10 but kept coming up with a weird black and white lined screen. Looked through forums and tried different things but eventually gave up.
3. Went back to installing 9.10 from usb which worked flawlessly. Probably because "nomodeset" is by default in the grub file
4. Used upgrade manager to then upgrade installation to 10.04LTS. This took all night.
5. Changed the /etc/default/grub

Code:
sudo gedit /etc/default/grub
add nomodeset as shown below in bold

Quote:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
save the file and type

Code:
sudo update-grub
You should then be able to boot normally without having to edit grub.

6. Installed the nvidia driver
had black screen of death on reboot so then did this:

reboot machine with shift button down to get grub.

run in recovery mode to get a console

run the nvidia-xconfig program:

cd /usr/lib/nvidia-96/bin/
sudo ./nvidia-xconfig

Modify the xorg.conf file, and replace the driver name nvidia with nv.

sudo vi /etc/X11/xorg.conf

Replace:

Driver         "nvidia"

With:

Driver         "nv"
Then just try and start the Xserver again:
startx

Still can't get 1600x1200 resolution but working on it.

7. Now moving on to Broadcom wirless driver
Just installed it activated it and it worked. Yeah!

1 Comments:

Anonymous Anonymous said...

As soon as you feel this super confident energy rush through your body, squeeze the index finger and thumb together hard. [url=http://www.mulberryhandbagssale.co.uk]Mulberry Mitzy Bags[/url] Your man might be hiding something from you if you have no longer access to all his communication devices. [url=http://www.goosecoatsale.ca]canada goose outerwear[/url] Sxygeqghk
[url=http://www.pandorajewelryvip.co.uk]pandora uk[/url] Jjegkzqlc [url=http://www.officialcanadagooseparkae.com]canada goose coats[/url] dvdssjmgc

12:07 AM  

Post a Comment

Links to this post:

Create a Link

<< Home